EDE on Alpine Linux

Alpine Linux is a security orientated Linux distribution that is extremely light-weight. Instead of the common glibc it uses µclibc (up to version 2.7.x) and the even smaller musl libc (beginning with version 3.0.0). It also uses a grsec patched kernel by default.

:!: Note: While EDE can cope with a non-standard libc, some parts of it do not work together with grsec's methods (as of version 2.1)! Alpine packages a vanilla kernel (without grsec) as well. This is what should be run right now for EDE to be usable on Alpine Linux.

Using EXPERIMENTAL packages

:!: Note: EDE is currently available for Alpine Linux in packages considered experimental. Try them out on non-critical systems only!
:!: Note 2: FLTK is not yet available from the Alpine Linux repositories. For that reason the EDE project provides a FLTK package as well.


At the moment experimental EDE packages are available for Alpine version 3.0.x on x86 only.

Packages available

  • fltk - The toolkit EDE depends on
  • edelib - EDE's support library which implements functions not provided by FLTK
  • ede - The DE itself: EDE binaries, configuration, icons, the wm, docs, etc.

Installing EDE

Before installing, make sure that you are running a vanilla kernel! You can use the following command for that:

:!: Note: Mind the accents (`) - they are not a single ticks (')!

if [ `uname -a | grep grsec | wc -l` -eq 0 ]; then echo "No grsec patched kernel. Good!"; else echo "Grsec patched kernel running. EDE will not work!"; fi

EDE for Alpine Linux is provided in packages only (i.e. no repository information for the package manager). Download the three packages from here. You can do so by issuing the following two commands (Mind the accents (`) again):

[ `apk info | grep wget | wc -l` -eq 1 ] || sudo apk add wget
wget http://ede.elderlinux.org/repos/_experimental/alpinelinux/x86/fltk-1.3.2-r0.apk http://ede.elderlinux.org/repos/_experimental/alpinelinux/x86/edelib-2.1-r0.apk http://ede.elderlinux.org/repos/_experimental/alpinelinux/x86/ede-2.1-r0.apk

Now you can install the packages:

apk add ./fltk-1.3.2-r0.apk ./edelib-2.1-r0.apk ./ede-2.1-r0.apk

Building / installing from source

You can of course follow the generic building procedure, too: InstallingFromSource. Just make sure to issue the following command from the source directory before you run “jam” (to fix a musl related issue):

sed -i -e '76a#include <sys/types.h>' ede-tip/ede-tip-compiler.c

Starting EDE

You can either use a graphical login manager to bring up EDE or simply use Xorg's startx command.

If you want to use startx, just create a new file .xinitrc with the content exec startede in your home directory. You can do so with the following command:

cd ~ && echo "exec startede" > .xinitrc