This is an old revision of the document!

EDE Installation Howto


Make sure you have listed requirements or EDE will not compile. If required packages has given version, please use that (or greater) release.

Required programs and libraries

This is the list of must-have programs and libraries or EDE and edelib (EDE Library) compilation will fail. All these programs and libraries already should came with your distribution as package (or as opt-in from package repository) and if they are not installed, please use your distribution specific installation procedure to install it.

  • C++ compiler (g++ >= 2.95 or newer, Clang or any recent SunStudio versions). Compiling with Intel C++ wasn't tested, but should be possible
  • FLTK >= 1.1.7
  • DBus >= 1.0
  • autoconf and aclocal (aclocal is part of automake package) are needed only if you downloaded EDE sources directly from the repository

Optional programs and libraries

This is the list of programs and libraries used by EDE and edelib we would like you have, but are not mandatory. If they are not present, certain features could be disabled.


  • doxygen - used to make API documentation
  • inotify (present in linux kernel since 2.6.13) or Gamin/Fam


  • python >= 2.3 - used to make documentation
  • UPower - comes with newer distributions (you can find more at
  • librsvg (only used rsvg tool) - used to create edeneu theme from .svg icons; this is only needed if you downloaded EDE directly from the repository
  • xscreensaver - should come with your distribution
  • cURL - used for bug report tool; it should come with your distribution

There is known issue «Bugzilla(156)» with python >= 2.6.2 and building EDE documentation. If you get into the problems as described in bug report, please use the solution given in the comment of that report.

EDE programs and libraries

This is the list of EDE related programs and libraries you should download from our download pages:

  • jam
  • edelib 2.0
  • ede 2.0

:!: If you are going to install EDE on default location (/usr/local), make sure you uninstall previous EDE version or use different prefix (like: ./configure –prefix=/opt/ede).

Compiling EDE

After you extracted each of EDE related programs, compile them in given order below.

Compile jam

Jam is make replacement we are using to compile EDE and edelib. Some distributions provides jam package so make sure it is official jam or ftjam; common version tody is Boost jam too, but EDE can't be compiled with it!

To see if it official jam, execute:

 jam -v

and if you get something like:

 Jam 2.5. OS=LINUX. Copyright 1993-2002 Christopher Seiwald.


 FT-Jam 2.5.3. OS=LINUX. (C) 1993-2003 Christopher Seiwald, see

then is ok. If you are not sure what jam version you have (but have already some), let edelib's configure script detects it and report if can be used. You can always download jam we are using from our download pages is you are not sure.

If you downloaded jam source, it already comes with Makefile, so running:


will compile it.

Installation is done by copying jam binary at the common binary location, like /usr/local/bin. Jam binary will be compiled in bin.YOUROS location, where YOUROS is operating system you are running, e.g. on Linux, jam will be in bin.linuxx86 and on FreeBSD will be in bin.freebsdx86. If you are using ftjam, binary directory will be bin.unix.

Copying is done with:

 cp bin.YOUROS/jam /usr/local/bin

Compiling edelib

In case you downloaded edelib from repository, make sure to run:


first and it will create correct configure script. If you downloaded official source release, this step is not needed because configure script is already created. The rest is:


and run jam (not make!):


and as superuser:

 jam install

Compiling ede

If you installed edelib with different prefix than /usr, export that path to pkg-config so it can find edelib libraries. To do so, run:

export PKG_CONFIG_PATH=<your-prefix>/lib/pkgconfig

Compiling ede is the same as for edelib. Also, if you downloaded ede sources from repository, make sure to run:


first, then:




and as superuser:

 jam install

:!: Note: if you downloaded ede source code from repository (ede2 module) default icon theme is not built, so you must do it manually. This is really simple procedure where you should pass only one parameter to jam tool (you have to have librsvg installed too). So, instead jam and jam install as given above, you should run:



 jam -sBUILD_ICON_THEMES=1 install

This will build ede and icon theme, installing both.

Starting EDE

If you are using display or login manager (like gdm, kdm or xdm) and you installed EDE with default prefix (it will use /usr by default), you will see session entry named EDE in display manager's list of available sessions. However, if you install EDE with different prefix, make sure to copy ede.desktop file (you will find it at <prefix>/share/xsessions/ede.desktop path) to /usr/share/xsessions folder, or configure your display manager to see EDE installation path.

If you are not using display manager (you start X session from terminal with startx command), put startede at the end of .xinitrc file (found in your home directory, like /home/your_username/.xinitrc, but make sure you comment previous window managers or desktop starting scripts if they exists.

If you do not have .xinitrc file in your home directory or you are not sure how things should be modified, here is a working sample you can copy and paste:


# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap

if [ -f $userresources ]; then
    xrdb -merge $userresources

if [ -f $usermodmap ]; then
    xmodmap $usermodmap

# Comment your previously used window managers or desktops
# /usr/bin/cool-window-manager
# /usr/local/bin/cool-desktop

# Start EDE


That would be it. Happy using and let us know what you are thinking about it. Please report any issues at